Showing results for 
Show  only  | Search instead for 
Did you mean: 
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Newcomer II

Cannot access Free for (ISC)² Members professional development courses

I can't seem to access the free for members courses located here:


If I click "Add To Cart", it wants me to pay. If I log into the site and try to enroll in one of the courses (e.g., the page at, and click "Free for members", it redirects me to the LMS page ( but no courses appear.


I've tried emailing member support about this, but have not received a response. I tried contacting D2L support via their web chat, and they said they would have to escalate the issue to (ISC)² support. So I have no idea how to get access to these courses. Any help would be appreciated.

57 Replies
Viewer III

Hi @Kaity 


I also have the access issue. I paid on Dec 21 but still not able to access those free courses.


Could you help me to check?




Community Manager

Hello @wilsonlee - I've reached out to my colleague in the education team to get this resolved. Hopefully you'll be all set this afternoon.

Newcomer I

It seems they have not resolved the issue with the free courses for members. I’m trying access now, been on chat with them and still not luck. I’ve disabled all security features on my device as they stated and still no luck.


Ironic how they demand you disable all security functions on your device to allow their product to work when they are a security body themselves. Am I the only one with an issue with this?

Newcomer I

I have since found that there are only 3 browsers which are supported. 

Chrome, Edge and Firefox. 

As soon as I went in through Chrome (instead of Safari), free member courses immediately worked! 

All security features on my device are switched on!! 

Community Champion

Thanks for feeding back.

Bit of a shame if it doesn’t work with Safari - after all it’s the second most popular browser by market share:

Hello team,

I'm having this same issue with my account. Would be nice to get back to some learning and earn some CPEs.

Ranjit Chougale
Viewer II

Yup, as of today I can't do it either. Tried 1-2 months ago before, didn't work either.


After clicking any of the "Free for Members" buttons on this page ( it directs to this page ( which used to say something along the line of "Your course has been added".


Then I don't see the course anywhere. And if I try to find the course under the catalogue/ store, it asks me to pay for it.


This kind of sucks, can't go through the content. Anybody managed to get help/ have it fixed?



Newcomer I

Hi David92,


I found using Google chrome allowed the free for members courses page to work. There is only a couple of browsers which are supported. 

Supported Browsers

  • Google Chrome
  • Microsoft Edge
  • Mozilla Firefox

Hope you gain access soon!