cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Champion

CPE 'new' portal continuing issues

 

It looks like the new CPE portal is still struggling to meet the operational requirements for the members. Some of my CPE credit submissions have no responses after 3-4 weeks, and I have no way to check if they are 'pending', 'auditing', or whatever. 

 

There is no auto response after submission, and there is no way to check the status. And since there is no sorting function on the approved CPE in either 'View' or 'Active Transcripts', one does not know easily and clearly which submission has been approved, thus has no idea which one should be resubmitted.

 

The loading is too slow, takes 10-15 seconds to reload, witch is every time you do to the page.

 

UX/UI design is NOT well thought out, often leaves one wonder which options to choose, For example, you have "Education Courses and Seminars" and "Online webinars, podcasts and other online materials", but the former is for attending webinar ( or is it since webinar is not mentioned? ), and the latter is for creating seminar/webinar materials. There are many other non-user-friendly UIs

 

Should we roll back to the old system?!

 

 


______________________________
Chuxing Chen, Ph.D., CISSP
Tags (2)
Community Manager

Re: CPEs Not Posting

Hello @Patkemoe & @Kanerf

 

Our teams are looking into the issues that you have brought up here. I encourage you to reach out to our Member Support team at membersupport@isc2.org so that they can assist you further with this. 

 

I will also be merging this post into a larger thread around this topic. This way you will get notifications through that thread as we make updates to the CPE Portal. 

 

Thanks, 

 

Samantha O'Connor
(ISC)² Online Community Manager
Newcomer I

Re: CPE 'new' portal continuing issues

ISC2 leadership team need to seriously investigate the composition of present team working on the ISC2 portal. In the name of enhancement it seems they handed the development of the portal over to a team of inexperienced people who completely messed it up.

 

I am in the same boat. Submitted some CPE no clue what will happen to those. Attended some e-Symposium seminars for which there is no tracking.

 

Now I think people will be in a dilemma whether we should spend any time earning the credit until the issue is completely resolved.

Community Manager

Re: CPE 'new' portal continuing issues

Hello @Chuxing & @npverma

 

Our teams are working on the issues that both of you have brought up about the new CPE Portal. In the meantime, you can reach out to our Member Support team at membersupport@isc2.org for assistance. 

 

I will also be merging your posts together with a larger thread on this topic. This way as we provide updates on the Portal, you will receive notifications. 

 

Thanks, 

 

Samantha O'Connor
(ISC)² Online Community Manager
Community Champion

Re: CPE 'new' portal continuing issues

 

I use to be PM for applications development, and know the challenges of such project. But one thing I would never do is to forklift the implementation without adequate testing, and this seems to be what have happened here. 

 

The architecture is another problem here - the DB integration with mid-tier is not well designed, thus the slow loading issue. The non-existing auto-acknowledging is another missed design, along with the lack of visibility by users into the status. Sorting can be relatively easy to remedy, but definitely needed. Th CPE 'view' display is badly designed IMHO, not very useful.

 

The UX needs to be seriously reconfigured, it is very confusing, and the option button descriptions need to be reviewed. 

 

 

 


______________________________
Chuxing Chen, Ph.D., CISSP
Newcomer I

An internal server error has occurred Error ID: 298296663-64610 (119852647)

Trying to enter CPEs.  Is it just me?  Very frustrated with this new "improved" process.  

Doug Pentek, CISSP
Tags (1)
Viewer

Re: An internal server error has occurred Error ID: 298296663-64610 (119852647)

I also am very frustrated.  I get loading...   loading....  loading...  forever.

 

I do NOT like this new system.  It functions poorly and is not even slightly customer friendly.

Newcomer III

Re: An internal server error has occurred Error ID: 298296663-64610 (119852647)

I have the same issue now for three weeks in a row. I reported it to member support and they tell me it seems to hit a number of people. They expect some answer/resolution by the end of the month.

 

There are more issues with the CPE portal, all combined into one item:

https://community.isc2.org/t5/Customer-Support/Updated-CPE-Portal-amp-Annual-requirements/m-p/9223#M...

Community Manager

Re: An internal server error has occurred Error ID: 298296663-64610 (119852647)

Hello @DougP@erwindus & @silktricks!  

 

As mentioned here by @erwindus, this is an issue that our team is working on. If you are running into any trouble, we encourage you to reach out to Member support at membersupport@isc2.org and they can assist you further. 

 

In the meantime, I am merging this into our larger thread that was mentioned in a previous reply. We will be updating this thread when we have any new information. This will ensure that you get updates on what is happening with the CPE Portal. 

 

Thanks, 

 

Samantha O'Connor
(ISC)² Online Community Manager
Newcomer I

Re: CPEs Not Posting

Thanks all.  I've submitted tickets.  Meanwhile I'm queuing up all my CPE entries until they get this mess cleaned up.

Doug Pentek, CISSP