cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Newcomer I

CPE portal: CISSP Domain 1 (Security and Risk Management) is missing

CPE-Portal.pngWhile updating my CPEs, I just noticed that the CISSP domain 1 (Security and Risk Management) is not displayed in the CPE portal. Unfortunately, 23.5 CPEs from 3 events belong to this domain, so that I can't finish submitting them. Does anybody have an idea how I can record the CPEs anyway?

 

 

 

5 Replies
Community Champion

Re: CPE portal: CISSP Domain 1 (Security and Risk Management) is missing

Just select the "second best" domain for the CPEs in question.  If you feel like you need to add an explanatory note as audit defense, put it in the "Review Text" on the previous page. 

 

As long as you are acting honestly and ethically in your reporting, I can not imagine that an auditor would give this more than a second glance.   (ISC)² is aware of this omission and is said to be working on a fix. 

Highlighted
Viewer II

Re: CPE portal: CISSP Domain 1 (Security and Risk Management) is missing

Hello,

I am encountering same issue and missing same domain for all of my CPE submission.
When I asked for explanation, I was told to choose 2nd best domain.

However, I am still in contact with ISC2 support to explain this situation. Unfortunately, they are not very responsive or helpful in that matter!

 

Thanks, Paul 

Highlighted
Viewer III

Re: CPE portal: CISSP Domain 1 (Security and Risk Management) is missing

I am having the same problem as well.  The entry form for CISSP CPEs (at least non-ISC2 education webinars) having a start date of January 12th, 2020 or earlier are missing the checkbox option for Domain 1 (Security and Risk Management).  I have not received a response back from ISC2 when I used the contact form, but maybe this forum might be more closely monitored.

Tags (3)
Highlighted
Viewer II

Re: CPE portal: CISSP Domain 1 (Security and Risk Management) is missing

Hello, it was fixed for me after I sent an email to support. It was fixed automatically after few weeks. I believe they have worked on that internally.