Showing results for 
Show  only  | Search instead for 
Did you mean: 
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Newcomer I

Facing error while submitting CPE for InfoSecurity Quiz

Hi Team,


On 17th April I cleared InfoSecurity quiz for March/April 2019 magazine. It's been more than 5 business days since then. When i try to submit my CPE point, it doesn't get uploaded. Here is the steps i take:

1. Enter begin & end date as 17 April 2019

2. Select 'YES' in option 'Have you fulfilled a CPE offered by ISC2'.

3. Select 'Submitted on behalf' in 'CPE type' option.

4. Select ISC2 infosecurity magazine as my option.

5. Then i provide name & CPE points and browse to the certificate stored on my computer and click 'upload attachment'. It gets uploaded too.

6. When i click final confirmation checkmark and click 'Request assistance', nothing happens and the circle just keeps moving. The request never gets submitted. Tried from different systems.


Attaching the screenshot for your reference. Please help.ISC2 Error.JPG

11 Replies

@Shannon I apologize for my delayed response but you are correct, the error is coming from checking 'yes' to the event being sponsored by (ISC)². This is still being worked on, so you will continue to have to check 'no' to that question in order to submit CPEs.


Best Regards,

Amanda Vance

Community Champion

@VinayRathee wrote:

@Shannon Thank you for this useful advice..I am collecting completion certificates for my every CPE activity in case I am audited.

Don't mention it; like they say, hope for the best and prepare for the worst...  Man Wink


Also, it might help to track the CPEs on your side --- say, using a spreadsheet --- to record the dates, sources, number of CPEs accrued, status, etc...





Shannon D'Cruz,