Showing results for 
Show  only  | Search instead for 
Did you mean: 
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Newcomer I

Cannot add CPE's: selection of domains not available

I wanted to add some more CPEs to my account, but it looks like with the rebranding of things, there is a bug in the system: Stuck in the selection of domains... no domains showing up... whats the issue here? Nothing happens when I click on ony of the certs... no domains showing up. Tried with firefox and chrome.




14 Replies

Hi All - I contacted support and received this temporary fix, which did work:


"Thank you for contacting member support, my apologies for the delay in our response.

I am sorry to hear of the issue you have been experiencing when attempting to add your CPE. We have recently launched our new website and whilst most things have thankfully worked as intended, this has thrown up a couple of issues with functionality, one of which being the CPE Portal.

Rest assured, our development team are working on this with the highest priority. Although a specific timeframe has not been advised, we are confident there will be a resolution to this issue very shortly.

In the meantime, we appreciate that adding CPE to your account is a fundamental step in maintaining your membership. Therefore, I am pleased to advise that the CPE Portal issue is only confined to a limited number of categories. I will list these below:

·      Industry Conference
·      Online webinars, podcasts and other online materials

·      Preparing New or Updating Existing Training Seminar or Classroom Material
·      Safe and Secure Online Presentations

All other categories are functioning correctly, and I would urge you to please utilize these categories if possible, in order to add your CPE activities. For example, an industry conference or an online webinar series could often be categorized under: Courses and Seminars - Other. Please always use your best judgement and if your activity cannot be categorized in any other way, then please respond to this email confirming this, I can then place your case on hold and advise you directly once the issue has been resolved.

I apologize for the inconvenience caused and if there is anything else I can assist you with, please do not hesitate to let me know.?"

Newcomer III

@Hikiashi wrote:

Stuck in the selection of domains... no domains showing up... whats the issue here?




Member Support sent me an update today to the support case I raised, reporting it as fixed. It does appear fixed for me, at least when selecting 'CPE Type: Industry Conference'.

Community Manager

I am hearing that the CPE Portal issue has been fixed and you can correctly report your CPE credits now. 


If you still have issues, please contact our team at

ISC2 Community Manager

Dear Team,


I am trying to submit my CPE for 2023 cycle, however there is no option to submit the CPE, is there some change? or is there an issue.


Please assist with the same.




3/31/2024 - went to enter CPEs and getting the same errors at the select domain section.   have found this to be an issue in various other threads.   This seems to be a systemic issue.   Does anyone know if the ability to enter CPEs is functioning via a workaround?