cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Newcomer III

Re: CPEs posting

I am always a fan of the saying "If you spend too long looking at a problem, you will be too distracted to look for the solution." That being said, I know that there are likely enough talented people here in the community that would be willing to look at, identify, and solve the issues with the CPE portal. 

 

As a message to the (ISC)2 member support: As a community, is there a way we, the members, can help fix the issues we are plagued by? 

 

Kevin

Highlighted
Viewer II

Re: CPEs posting

I had a similar issue posting CPEs. Very frustrating but I hope it gets resolved soon.

Highlighted
Viewer III

Re: CPEs posting

I'm having issues especially with CPE's related to ISC2 education/webinars etc that are supposed to update your CPE record automatically, this doesn't seem to happen any more. The CPE portal is ridiculous, it won't let you enter the CPE's yourself if it is less than 5 days since you completed the CPE and after 5 days you get the "Request Assistance" option as your only way forward which of course does not work ! I have emailed member support services repeatedly and get no response. My 3 year membership cycle is up in a few days so I guess I will be "de-certified" as I have read has happened to others so then I will have to fight it out with non-responsive member support services. All a bit disappointing as these issues seem to have been around for a long time and nothing has been done to fix them.

 

Strangely the website was able to take my payment without any issues whatsoever !

Highlighted
Community Champion

Re: CPEs posting


@SteveB wrote:

I'm having issues especially with CPE's related to ISC2 education/webinars etc that are supposed to update your CPE record automatically, this doesn't seem to happen any more. The CPE portal is ridiculous, it won't let you enter the CPE's yourself if it is less than 5 days since you completed the CPE and after 5 days you get the "Request Assistance" option as your only way forward which of course does not work ! I have emailed member support services repeatedly and get no response. My 3 year membership cycle is up in a few days so I guess I will be "de-certified" as I have read has happened to others so then I will have to fight it out with non-responsive member support services. All a bit disappointing as these issues seem to have been around for a long time and nothing has been done to fix them.

 

Strangely the website was able to take my payment without any issues whatsoever !


Sounds like you're selecting "Yes" to the option "Have you fulfilled a CPE offered by (ISC)²" when manually adding the CPEs - this option is known to be problematic.

 

Please follow the steps shown in the link below to manually enter all Group A CPEs:

 

https://community.isc2.org/t5/Member-Support/CPE-not-getting-credited-automatically/m-p/21405#M4085

 

These steps uses known "working" options.

 

Highlighted
Viewer III

Re: CPEs posting

Thanks Alec, you are right I was selecting "Yes" to the option "Have you fulfilled a CPE offered by (ISC)²". I am aware that I can work around the issue but thanks for letting me know that it is a legitimate solution. I was a bit concerned about entering ISC2 CPEs as non-ISC2.