cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Viewer

CPE not getting update

It is almost more then 20 days that my CPE's are not getting reflected from my Brighttalk account.

I have been Emailing Member Support constantly but no response.

 

Kindly look into the matter.

 

Also have some courtesy to give response to members Email.

 

Regards,

 

Dawood Kevar

2 Replies
Advocate I

Re: CPE not getting update

There's a 3-4 week wait to get a response via email due to the numerous issues being experienced at the moment.

 

Feel free to add your CPEs manually using the steps found in this post:

 

https://community.isc2.org/t5/Member-Support/CPE-not-getting-credited-automatically/m-p/21405#M4085

 

If you then find the CPEs do also get added automatically later down the line just delete the duplicate entries.

 

Community Champion

Re: CPE not getting update

 

@kdawood the BrighTalk moderator usually states that while the CPEs should be credited to the (ISC)2 account automatically, this depends on two factors: 

 

  1. You've linked your BrighTalk account to your (ISC)2 member ID. If you didn't do that, follow directions here.
  2. You've watched at least 45 minutes of the webinar --- whether live or archived. To confirm that, go to My Account > My viewing history to get a list of what you viewed along with certificates to prove that.

If you do indeed have the certificates, as @AlecTrevelyan said, just add them manually, but ensure that you periodically check your CPE transcript & delete duplicates if they're added later --- you don't want to tempt the auditors. (To be on the safe side, download the certificates)

 

 

Shannon D'Cruz,
CISM, CISSP

www.linkedin.com/in/shannondcruz