cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
(ISC)² Former Staff

Re: Problem entering CPEs

This error is happening with a few of our members. We are working to get this corrected as quickly as possible. I will let you know when it is corrected.
Contributor II

Re: Problem entering CPEs

Thanks again :-)
--
Heinrich W. Klöpping, MSc CISSP CCSP CIPP/E SCI
Newcomer III

Horrible new way of viewing/registering CPEs

Today I noticed the option to view/add CPEs has changed. And not in a positive way.

 

Previously, a list sorted by date showed you your CPEs. At the bottom a button to add new CPEs. Although certainly not a modern look, it was functional as the list was sorted on date-order, so it was easy to see what you may have missed to add in the past.

 

Now the top part of the screen is the option to add CPEs, so you don't need to scroll down to add CPEs. Good.

 

However, there's no overview. You need to click another button to get to the overview. And this overview, well, this overview is useless. There are three columns with 'cards', unsorted, with blank spots in the columns. It's not an overview, its like a deck of cards that fell on the ground. Why not a sorted list? That's an overview and it takes less space on screen (no scrolling down to see what's there). And while I'm at it, can we also have a 'back' button on top and not only at the bottom of this overview?

 

Next, I had a look at the transcript. At least that's a list, but unfortunately, again, unsorted. Why?

 

Finally, I tried to add new CPEs. I need to get used to the new options I have to choose (I'll get that in the near future), but I got to the point where I could save my entry. Then it said this:

 

Capture.PNG

 

 

This confused me. Did I do something wrong? I can't find the entry I just made, so I don't know. Is it because it is 'gone' (there is an error message)? Or is it invisible because it's under review? If the latter, why not make it visible as 'under review'?

 

So, as a real IT guy, at the end, I tried to open the CPE manual. Tried, as the progress bar appeared which got stuck at 223kB/12MB, changing into 223kB/1,2MB, and then it complete crashed my browser. Stuck, nowhere to be moved, so I had to kill the process and start over again.

 

Am I happy with this new look/feel? Not yet at all. I'm hoping this is just the usual problematic startup of something new, while improvements are waiting around the corner.

 

What are your views?

Highlighted
Viewer II

CPE credits not added automatically

I have noticed that my CPE credits are not being added automatically from brightalk and bluesky accounts. It was getting added in the old portal. After the new portal migration the CPE's are not reflecting accurately. The new CPE view does not display the full name of the topic and hence it is difficult to track the CPE's. 

Tags (2)
Contributor II

Re: Horrible new way of viewing/registering CPEs

You may want to read this post for some additional thoughts / observations.

--
Heinrich W. Klöpping, MSc CISSP CCSP CIPP/E SCI
Newcomer III

Re: Horrible new way of viewing/registering CPEs

I noticed your post before I posted mine. Your error message is different, you do see what you've entered and your issue was (partially?) solved.

I don't see what I did, so I need a solution. The rest of my post has to do with the layout of the views/lists and some ideas how it could be enhanced.

Viewer

Re: CPE credits not added automatically

Agree, not sure this is working properly yet.

Contributor II

Re: Horrible new way of viewing/registering CPEs

No doubt somebody that can help you resolve the problem will contact you soon, they did with me. I was referring to my post just to indicate that there seem to be more problems with the new CPE registration software.  Perhaps we could use this thread to "dump" our issues in, so that others in the community can see what already has been reported and save them the trouble.

 

One of my additional observations: the report (transcript) is haphazardly spread across the pages, the older format was much more pleasant looking / functional. See pic below.

a.png

 

--
Heinrich W. Klöpping, MSc CISSP CCSP CIPP/E SCI
Community Champion

Re: CPE credits not added automatically

Automatic cpe submission has always been flaky.  I have had problems with it since well before the switch to the new interface.

 

You can see the complete title by looking at the page source on the "view my CPEs" page. It is somewhat buried, but that is what "find in page" is for :-).

 

Others have already (in this forum) reported this to (ISC)² and they have replied that it is on their to-fix list, including on the PDF reports.

Newcomer II

Re: Problem entering CPEs

I have to admit the lack of sorting affected me more than expected. It should really be resolved soon.

I was able to successfully enter my multi-domain CPE. However, when I viewed the active transcript it displayed that entry with only one domain. Although the dashboard view lists all the domains correctly.