cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Viewer II

Updated CPE Portal & Annual requirements

I just jumped on the portal to submit some CPE requests for podcasts.  It appears that the portal has a glitch that doesn't recognise that means it doesn't remove the 250-500 word "book review" requirement for the podcasts, which makes it quite painful to submit the request.  I have also found that if you are too close to either end (250 or 500), it glitches and tells you you haven't reached the 250-500 word limit.

Tags (1)
243 Replies
Community Champion

Re: Updated CPE Annual requirements

My submission also was for "Online webinars, podcasts and other online materials".  I was not obliged to complete the "Review Text" field.  I am using Chrome 65 on Window 10. Perhaps you have found a browser-specific bug.

(ISC)² Team

Re: Updated CPE Annual requirements

We have noted this and are in the process of making the appropriate adjustments.

 

Thank you for providing us that feedback and for your patience during this transition. We appreciate your support.

 

Best regards,

Beth

Senior Corporate Member Services Manager

Community Champion

Re: Updated CPE Annual requirements

While submitting a "webcast" CPE, the "review text" field is not required, but remains available to be optionally completed.  I observed that the form would not submit if I enter a single character, but it worked the moment I cleared the field.  Apparently (and matching the label), one must enter either 0 characters or one must enter 250-500 words.

 

@netzwerg, could it be that you left a space in the review text?

Highlighted
Viewer II

Re: Updated CPE Annual requirements

Yeah, I worked out what the issue was.  If you submit a podcast CPE credit request, and don't put anything in the review text box, then it is accepted.  If, however, you enter any text in the box, it must be between 250-500 words.  That matches exactly with what you are saying @denbesten.

 

So, why would I have entered text?  Well, in order to provide some evidence that I had listened to said podcast, I wanted to enter the link to the podcast.

 

Thanks for looking into it, @denbesten.

Contributor II

Problem entering CPEs

As I noticed today, a new system for registering your CPE's was put in place. First impressions: it's more intuitive, has a flow to it, so yes, might do well. Alas, after registering my new CPEs and finishing the registration (no problems at all)  I found a new heading on my front page under which my CPEs seem to have ended up: the banner reads "CPEs that need attention". This, to me at least, suggests that it would be ME that needs to give (further?) attention to the CPEs. "So", I guessed, "perhaps I forgot to enter something or made a mistake or what, let's see" - and so I re-entered the process.

 

Nope, all seems allright - until I got to the page "Apply CPEs" again. As I hold two certifications and the CPEs I wanted to enter should be valid for both, I had previously checked both domains (Group B). And that still showed up correctly. So, I hit [Save and Continue] - only to be returned to the same page, now stating that I should at least select one domain. O, well, but I just DID! .. er.. help?

 

See the picture below:

Screenshot at 2018-04-16 16-00-23.png

 

So, what am I doing wrong here?

 

If the error is a result of my assumption that I still should enter additional data, well, at least to me the header "CPEs that need attention" and the subheader: "continue submitting your CPE" strongly suggests this. But in any case it should not be possible to have two ticks set and still get the message shown above.

 

So, what can I do?

 

ETA: sometimes these errors occur because the javascript interpreter in your browser has a glitch, in which case a full restart of the browser might work. I tried that, but alas, to no avail.

--
Heinrich W. Klöpping, MSc CISSP CCSP CIPP/E SCI
(ISC)² Former Staff

Re: Problem entering CPEs

Hello Heinrich,
After reviewing your records, I was able to complete your submission. The CPEs were applied to your CISSP and CCSP certifications. I was not able to locate the error; however, I will keep looking.

Thank you for your membership and patience through this transition.

Kind Regards,

Laura Schneiter
Contributor II

Re: Problem entering CPEs

Thanks, Laura :-)

--
Heinrich W. Klöpping, MSc CISSP CCSP CIPP/E SCI
Contributor II

Re: Problem entering CPEs

Another one rears its ugly head. After (as a logged in  user) clicking the 'submit / edit my CPE credits' button the following screen shows up:

 

Screenshot at 2018-04-16 18-41-54.png

 

--
Heinrich W. Klöpping, MSc CISSP CCSP CIPP/E SCI
Contributor II

Re: Problem entering CPEs

.. and I could actually log in there, then was asked some questions about my security question etc. and then got to the place I'd expect to come to automatically. Somehow the IAM structure seems to fail me?
--
Heinrich W. Klöpping, MSc CISSP CCSP CIPP/E SCI